How to convert scenarios from 1.1 to 1.2??

  • francof514
  • francof514's Avatar
  •  
  • Rare hypaspist
  • Rare hypaspist
  •  
  • Posts: 66
  • Thank you received: 27
Francof514 posted: 20 Dec 2016 01:03
Hi again, just want to ask how to convert the scenarios between version becuase some of those dont load and want to know what to do about that..
 

Please Log in or Create an account to join the conversation.

  • musictopia
  • musictopia's Avatar
  •  
  • Rare hypaspist
  • Rare hypaspist
  •  
  • Posts: 96
  • Thank you received: 36
Musictopia answered: 20 Dec 2016 22:43
If you let me know which ones they are, I can somehow make them work for 1.2.
 

Please Log in or Create an account to join the conversation.

  • francof514
  • francof514's Avatar
  •  
  • Rare hypaspist
  • Rare hypaspist
  •  
  • Posts: 66
  • Thank you received: 27
Francof514 answered: 30 Dec 2016 22:03

musictopia wrote: If you let me know which ones they are, I can somehow make them work for 1.2.


Yes mines ones, but i wanted to do myself.
 

Please Log in or Create an account to join the conversation.

  • musictopia
  • musictopia's Avatar
  •  
  • Rare hypaspist
  • Rare hypaspist
  •  
  • Posts: 96
  • Thank you received: 36
Musictopia answered: 31 Dec 2016 13:11
The most complex part is there are some triggers that used the 1.1 version. They have to be changed to the 1.2 versions.

The most common ones that need to be changed are:
_EMLoader (there were changes to the emulation triggers)
_GameSettings (there may have been changes to the game settings)

what needs to be done is you have to manually delete the triggers and then put them back in. When you put them back in, it should only show the 1.2 version, not the 1.1 versions assuming you made completely new folders for the latest version and not copying the triggers from 1.1 to 1.2.
 

Please Log in or Create an account to join the conversation.

  • francof514
  • francof514's Avatar
  •  
  • Rare hypaspist
  • Rare hypaspist
  •  
  • Posts: 66
  • Thank you received: 27
Francof514 answered: 02 Jan 2017 22:47

musictopia wrote: The most complex part is there are some triggers that used the 1.1 version. They have to be changed to the 1.2 versions.

The most common ones that need to be changed are:
_EMLoader (there were changes to the emulation triggers)
_GameSettings (there may have been changes to the game settings)

what needs to be done is you have to manually delete the triggers and then put them back in. When you put them back in, it should only show the 1.2 version, not the 1.1 versions assuming you made completely new folders for the latest version and not copying the triggers from 1.1 to 1.2.


Yes, i was trying to do that, but also in opposite way, becuase 1.1 use old version that contain some debug code, i think is important to mantain compatibility.
 

Please Log in or Create an account to join the conversation.